Tableau Connectors


Connect to hundreds of data sources

  • Tableau Server Data Sources
  • Actian Matrix*
  • Actian Vector 2.0 or later*
  • Amazon Athena
  • Amazon Aurora
  • Amazon Elastic MapReduce
  • Amazon Redshift
  • Anaplan
  • Apache Drill
  • Aster database
  • Box
  • TIBCO┬« Data Virtualization
  • Cloudera Hadoop Hive and Impala; Hive CDH3u1, which includes Hive .71, or later; Impala 1.0 or later (incl. Kerberos support for Impala)
  • DataStax Enterprise Edition 2.2 or later*
  • Denodo
  • Dropbox
  • EXASOL 4.2 or later*
  • Firebird 2.1.4 or later
  • Google Ads
  • Google Analytics
  • Google BigQuery
  • Google Cloud SQL
  • Google Sheets
  • Hortonworks Hadoop Hive 1.1 or later
  • HP Vertica 8.1 or later
  • IBM BigInsights*
  • IBM DB2 9.1 or later for Linux, UNIX, or Windows (available on Tableau Desktop/Server on Windows only)
  • IBM PDA Netezza 4.6 or later*
  • JSON files
  • Kognitio
  • MapR Distribution for Apache Hadoop 2.x or later*
  • MariaDB
  • Marketo
  • MarkLogic 7.0 and 8.0
  • MemSQL
  • Microsoft Access 2007 or later*
  • Microsoft Azure Data Lake
  • Microsoft Azure Data Warehouse
  • Microsoft Azure DB
  • Microsoft Excel 2007 or later
  • Microsoft OneDrive
  • Microsoft PowerPivot 2008 or later*
  • Microsoft SharePoint Lists, default list view only
  • Microsoft Spark on HDInsight
  • Microsoft SQL Server 2005 or later (incl. support for Kerberos)
  • Microsoft SQL Server Analysis Services 2005 or later, non-tabular mode only*(incl. support for Kerberos)
  • Microsoft SQL Server PDW V2 or later
  • MonetDB
  • MongoDB BI
  • MySQL 5.5 or later
  • OData
  • Oracle Database 11g Release 2 or later
  • Oracle Eloqua
  • Oracle Hyperion Essbase 11.1.1 or later*
  • PDF
  • Pivotal Greenplum 4.x or later
  • PostgreSQL 8.3 or later
  • Presto
  • Progress OpenEdge 10.2B patch 4 or later*
  • QuickBooks Online
  • Salesforce.com, including Force.com and Database.com
  • SAP HANA 1.0035 or later
  • SAP NetWeaver Business Warehouse 7.00 with SP20+ recommended; also requires SAP GUI for Windows 7.20 or later client*
  • SAP Sybase ASE 15.7 or later*
  • SAP Sybase IQ 16 or later*
  • ServiceNow ITSM
  • Snowflake
  • Spark SQL requires Apache Spark 1.2.1 or later
  • Spatial files (Esri Shapefiles, KML, GeoJSON, and MapInfo file types)
  • Splunk Enterprise 6 or later*
  • Statistical Files; SAS (*.sas7bdat), SPSS (*.sav), and R (*.rdata, *.rda)
  • Tableau Data Extract
  • Teradata 15.00.00 or later
  • Teradata Aster Data nCluster 5.0 or later
  • Teradata OLAP Connector 14.10 or later*
  • Text files -- comma separated value (.csv) files
  • Additional databases and applications that are ODBC 3.0 compliant
  • Tons of web data with the Web Data Connector

* Available for Windows only

Cookies make it easier for us to provide you with our services. With the usage of our services you permit us to use cookies.
More information Ok